2003 f350 6.0 misses - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 12-06-2009, 04:08 PM
Powerstroke.org Rookie
 

Join Date: Dec 2009
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
2003 f350 6.0 misses

I have a 2003 f350 6.0 with 246000 miles, it starts good when cold but it seems like its only runs on 4 or 5 cylinders. When it warms up if you stomp it to the floor it bucks and surges, if you are driving it on the highway and start up a hill and gas on it a little bit it will buck and surge any ideas.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 12-06-2009, 04:14 PM
Banned
 

Join Date: Dec 2008
Posts: 2,850
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Has the truck had the latest reflash done by the dealer? It should help with cold starts. Do you have anyway to check for codes? Welcome to the Org as well
Reply With Quote Quick reply to this message
  #3  
Old 12-06-2009, 04:30 PM
Powerstroke.org Rookie
 

Join Date: Dec 2009
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks for the reply. i can't check the codes. my dealer says it needs 8 new injectors. just don't belive it. some say it oil pressure or the icp. I don't know were to start.
Reply With Quote Quick reply to this message
  #4  
Old 12-06-2009, 04:33 PM
Banned
 

Join Date: Dec 2008
Posts: 2,850
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
If you had access to a scan tool you could run a test on your injectors. I would at least try that before spending a lot of money on injectors.
Reply With Quote Quick reply to this message
  #5  
Old 12-06-2009, 04:46 PM
Powerstroke.org Rookie
 

Join Date: Dec 2009
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I'll have it checked and get back to you in the moring. Thanks
Reply With Quote Quick reply to this message
  #6  
Old 12-06-2009, 04:47 PM
Super Moderator

 

Join Date: Nov 2008
Posts: 13,275
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
I agree with it being an injector issue but it might not be all 8. The new flash from Ford would help with start ups but its not going to fix your "miss"
Reply With Quote Quick reply to this message
  #7  
Old 12-07-2009, 06:44 AM
Premium Member
 

Join Date: Nov 2007
Location: Buffalo, NY
Posts: 1,824
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
My truck is doing this at 100,325 miles and its an 06. I would think that my issues are partially brought on by running Veggie but non the less I think the problem is injector related just have to find out which one or few.
Reply With Quote Quick reply to this message
  #8  
Old 12-07-2009, 11:53 AM
Super Moderator

 

Join Date: Nov 2008
Posts: 13,275
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Quote:
Originally Posted by AFBLUE View Post
My truck is doing this at 100,325 miles and its an 06. I would think that my issues are partially brought on by running Veggie but non the less I think the problem is injector related just have to find out which one or few.
Could be the veggie, could be diesel. Only way to find out is with a good scanner
Reply With Quote Quick reply to this message
  #9  
Old 12-07-2009, 12:01 PM
Emergency Services
 

Join Date: Jul 2008
Location: phoenix
Posts: 22
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
have the same truck and my y pipe was leaking and my ficm also had a loose wire which wasnt letting number 8 cylinder get fuel
Reply With Quote Quick reply to this message
  #10  
Old 12-07-2009, 01:41 PM
Powerstroke.org Rookie
 

Join Date: Dec 2009
Posts: 25
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
found a wire coming out of the ficm rubbing the valve cover and the ground was loose who ever was there didn't tighten it. it fixed the problem on take off, i can stomp it to the floor and it runs great, but in over drive it still has a little stager in it, when i'm gently gas on it going up a hill.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:07 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors