a few ? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 12-03-2009, 07:30 PM Thread Starter
Member
 
biggish's Avatar
 
Join Date: Aug 2007
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
a few ?

hey everybody, my 04 f350 drw lariet, truck has a few bugs just started here goes,
4 wheel drive quit working on auto light comes on no go,very little heat at idle and the hydro booster is making a god awfull sound which will give me very little brakes at times

so with the no heat im gonna check heater core hoses in morning if there good and hot is that good?
im also going to change my t-stat tomorrow as well it was changed last year for the same issue but here we go again did fix it for a while, what about the water pump how do i check it?

as for the four wheel drive any thoughts? where do i start my truck works hard everyday it has 300000 km on it has 4 inch turbo back,egr,cooler delete aem intake and have a hypertech in it stage 2
i will also change the hydro in the am again! also truck does not show signs of puking or loss of coolant and is full sorry about the long post just need good ideas and you guys rock!!!

2004 f350 dually cc
4 turbo back mbrp
afe intake
big set of balls
biggish is offline  
post #2 of 5 Old 12-04-2009, 11:33 PM
Premium Member

 
Goose350's Avatar
 
Join Date: Nov 2008
Posts: 13,271
Thanks: 0
Thanked 5 Times in 5 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
You more than likely have a leak in your hubs or vacuum lines. Does the 4x4 work when you lock the hubs?

The Mullet Mod
Stock 2005 F-350 4x4
*Afe Intake
*4" TB Exhaust
*Scangauge
*SCT
*Bulletproof Diesel oil bypass
*Bulletproof Diesel water pump
*Tuned FICM
Goose350 is offline  
post #3 of 5 Old 12-06-2009, 05:52 PM Thread Starter
Member
 
biggish's Avatar
 
Join Date: Aug 2007
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
yes it works when i lock it in, i changed the heater core and thermo and my hydro boost works good now i have heat like never before wow!! but in auto mode for the 4 by nothing the light comes on heat stops blowing from the floor for a few sec and will only blow defrost then com back to floor but no 4 by

2004 f350 dually cc
4 turbo back mbrp
afe intake
big set of balls
biggish is offline  
post #4 of 5 Old 12-06-2009, 05:54 PM
Premium Member

 
Goose350's Avatar
 
Join Date: Nov 2008
Posts: 13,271
Thanks: 0
Thanked 5 Times in 5 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
You have a leak in your vacuum lines. I would also check them to make sure they are connected.

The Mullet Mod
Stock 2005 F-350 4x4
*Afe Intake
*4" TB Exhaust
*Scangauge
*SCT
*Bulletproof Diesel oil bypass
*Bulletproof Diesel water pump
*Tuned FICM
Goose350 is offline  
post #5 of 5 Old 12-06-2009, 07:19 PM Thread Starter
Member
 
biggish's Avatar
 
Join Date: Aug 2007
Posts: 55
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
were do i find all lines is there a diagram somewhere i could see thanks for the help

2004 f350 dually cc
4 turbo back mbrp
afe intake
big set of balls
biggish is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome