code -P006? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 11-19-2009, 01:38 PM Thread Starter
Compression Ignition Addict
 
doubleh1's Avatar
 
Join Date: Jul 2009
Location: southern california
Posts: 181
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
code -P006?

I posted a few days ago about a possible fuel pump issue. Couldnt figure it out. So I got it towed to the dealership and turns out it was a fuel acuator or something? Some valve up in the secondary filter. Well, I go and pick the truck up yesterday and drive it home. I notice a weird sound when I pull off the line at about half throttle 1200 rpms or so. Kinda like a loud, vibrating sound. Comeing from the passenger side somewhere. So i got home and popped the hood and noticed the tube from the turbo wasn't connected properly to the air filter housing. So I fixed that. Now this morning the dang CEL came on again. It has the code P006? AMBIENT AIR TEMP SENSOR CIRCUIT. What does that mean? Where do I begin to try and fix this problem? It's a 2003 6.0. Would that cause the weird, loud vibrating sound in the floor board?

I'm seriously about sick of this. Everytime I get something fixed, something else goes wrong. I feel like a ford 6.0 mechanic now, i've been in and under that truck more than anything since I got it. I officially detered my neighborhood from buying fords. They are always seeing me working on it and they even witnessed it getting towed

I test drove an 04 today, just to compare it to my truck. It had 52000 miles on it for 32000. I honestly believe my truck ran better than that one, so hopefully this isn't too hard of a fix. Im' frustrated with this truck. It's always something..
doubleh1 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 11-19-2009, 03:39 PM Thread Starter
Compression Ignition Addict
 
doubleh1's Avatar
 
Join Date: Jul 2009
Location: southern california
Posts: 181
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
anyone have any input?
doubleh1 is offline  
post #3 of 4 Old 11-19-2009, 04:04 PM Thread Starter
Compression Ignition Addict
 
doubleh1's Avatar
 
Join Date: Jul 2009
Location: southern california
Posts: 181
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
now i have P0098. Could any of this have anything to do with the EGR DELETE I did 3 weeks ago?
doubleh1 is offline  
post #4 of 4 Old 11-19-2009, 06:36 PM Thread Starter
Compression Ignition Addict
 
doubleh1's Avatar
 
Join Date: Jul 2009
Location: southern california
Posts: 181
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
bump bump bump
doubleh1 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome