HPOP issues... cant figure it out... - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 11-10-2009, 02:54 PM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: Norfolk Va
Posts: 156
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
HPOP issues... cant figure it out...

04' 6.0/92,000miles/egr delete/5" exhaust

the issue im having is that my truck shuts off when it gets warm and wont restart untill the engine temp goes back down. When i initialy took the truck in after this happend it was throwing low current codes on four injectors and a FICM code. ive changed icp/pigtail, crank, cam sensors, FICM/Reflash. ive also tore down the HPO rails, all of the orings are fine. checked the ipr, the orings are ok and the screen was clean. once the truck shuts off when its warm its still hard to restart. If you wait till the engine temp goes back down it will fire rite back up. im at a loss still. im gona build a gauge setup for my hpo rail and icp sensor tomarow. my truck has also been lacking power lately, would that be a sign of a dying hpop or ipr...?????
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 11-10-2009, 05:25 PM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Jefferson, Ga
Posts: 673
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The injector O-rings, pump output fitting, standpipe from oil rail to branch tube under head, and branch tube itself are all possible sources of an ICP leak.
Reply With Quote Quick reply to this message
  #3  
Old 11-10-2009, 05:28 PM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,259
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
Without codes and some live data readings all anyone can do is best guess.
There are several after market scanners available for relatively low prices. Most any aftermarket parts store will have them. Acutron; Actronics; Autoxray all under $500.00
Any brand will do as long as it is CAN capable and can read live data. These would be good enough for general trouble shooting.
Reply With Quote Quick reply to this message
  #4  
Old 11-11-2009, 02:36 AM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: Norfolk Va
Posts: 156
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by ajpu1983 View Post
The injector O-rings, pump output fitting, standpipe from oil rail to branch tube under head, and branch tube itself are all possible sources of an ICP leak.
the injector O-rings looked ok when i removed the oil rails. The thing that makes trouble shooting or working on this truck such a PITA is that im in the navy and live in the barracks... im going to build me a gauge with a t-block that i can mount my icp sensor and a gauge into tonight... i still have a feeling that its a hpop, mainly because the truck has felt so underpowered lately. thanks for the reply though.
Reply With Quote Quick reply to this message
  #5  
Old 11-11-2009, 07:55 AM
Powerstroke Techie

 

Join Date: Jun 2008
Location: Brampton, Ontario, Canada
Posts: 2,584
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Quote:
Originally Posted by STORMTROOPIN View Post
the injector O-rings looked ok when i removed the oil rails. The thing that makes trouble shooting or working on this truck such a PITA is that im in the navy and live in the barracks... im going to build me a gauge with a t-block that i can mount my icp sensor and a gauge into tonight... i still have a feeling that its a hpop, mainly because the truck has felt so underpowered lately. thanks for the reply though.
What is the exact build date for this truck? What is the mileage? What grade of oil are you using? Are you using the proper factory Ford FL-2016 oil filter, or those garbage aftermarket filters that use the one-piece cap and filter assembly?
Reply With Quote Quick reply to this message
  #6  
Old 11-11-2009, 11:32 AM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: Norfolk Va
Posts: 156
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by m-chan68 View Post
What is the exact build date for this truck? What is the mileage? What grade of oil are you using? Are you using the proper factory Ford FL-2016 oil filter, or those garbage aftermarket filters that use the one-piece cap and filter assembly?
my truck is a late model 04' im not possitive on the build date but i can get it latter. The truck has 92k on it and i am using rotella 15w-40. Yes i am using the factory motorcraft filter. The one i took out of it last time was one of those junk after market deals.
Reply With Quote Quick reply to this message
  #7  
Old 11-12-2009, 12:01 AM
Powerstroke.org Fanatic
 

Join Date: May 2009
Location: phoenix
Posts: 119
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
you said you had codes for 4 injectors and a ficm code? maybe your ficm is going out
Reply With Quote Quick reply to this message
  #8  
Old 11-12-2009, 02:30 AM
Compression Ignition Addict
 

Join Date: Mar 2009
Location: Norfolk Va
Posts: 156
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by jsr86 View Post
you said you had codes for 4 injectors and a ficm code? maybe your ficm is going out
ive already changed the ficm, along with both crank and cam sensors, icp and pigtail, checked the o rings in the oil rails. My dad is a supervisor/mech at a buss garage back home and they use the 6.0's so he hooked me up with there international tech. Im going to replace every single o-ring in that hpo system. IM gona bias the ipr first and presurize the system to make sure it isnt the pump first. I dont belive its the pump anymore but im going to give it a shot. Hey how much is a oil cooler rebuild kit....???? does anyone know where i can get a good price on both fuel filters????
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 05:29 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors