need help! truck at its LPOP now won't start - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-25-2009, 07:30 PM
Compression Ignition Addict
 

Join Date: Feb 2007
Location: Worthington, Indiana
Posts: 578
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
need help! truck at its LPOP now won't start

Hello guys, okay my truck died on the road last sunday. I tore it down changed the LPOP and front cover, I got it all buttoned up and now it wont start. It will not fill up the oil filter bowl either. What do I need to do? what is the next step?

This is gonna sound dumb but how does the LPOP get oil from as high off the pan as it is? Also what would cause this? I had one whole tooth come off one of the gears and it was cracked in 4 spots.

Thank you guys for reading and please help!
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 10-26-2009, 05:12 PM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,255
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
Well being an old world mechanic I pack the pump with engine molly to help it pick up oil from the sump. I have been told that this is no longer necessary, but old habits die hard.

All I can say fer myself is in 44 years I have not had one fail to prime up from the get go.
Reply With Quote Quick reply to this message
  #3  
Old 10-26-2009, 05:24 PM
If it aint a CAT itsa DOG

 

Join Date: Apr 2007
Location: North Branch, MN
Posts: 4,545
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
here is a bump for you bud, good luck!
Reply With Quote Quick reply to this message
  #4  
Old 10-27-2009, 01:31 AM
Compression Ignition Addict
 

Join Date: Dec 2008
Location: port arthur texas
Posts: 3,255
Thanks: 0
Thanked 11 Times in 11 Posts
Feedback Score: 0 reviews
I just snapped to something you asked. Your oil pickup tube was still attached to the pump suction was it not.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 08:34 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors