Front Cover cracked? - Ford Powerstroke Diesel Forum
 
LinkBack Thread Tools Display Modes
post #1 of 5 Old 10-13-2009, 11:20 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Jun 2007
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
Front Cover cracked?

I had an issue with my 05 F250 a little over a week ago. After cranking to leave a parking spot, the truck died and then would not re-crank. Had it towed to the nearest Ford Dealer and their diagnosis is that there was a problem with the Front Cover (cracked?). They replaced the Front Cover and pulled the oil pan to check for metal shavings (they say they found none).

They explain the No Start due to low oil pressure, the PCM wouldnt allow the truck to crank.

Has anyone heard of this happening? anyone with a similair experience? This explanation/repair just isnt passing the sniff test with me so far.
Chris4x4gill2 is offline  
post #2 of 5 Old 10-13-2009, 11:27 AM
Premium Member
 
Snake's Avatar
 
Join Date: Mar 2008
Location: FL
Posts: 4,715
Thanks: 57
Thanked 94 Times in 75 Posts
Mentioned: 1 Post(s)
Quoted: 46 Post(s)
Feedback Score: 0 reviews
Front Cover? Huh?

--Snake
Snake is offline  
post #3 of 5 Old 10-13-2009, 11:35 AM Thread Starter
Powerstroke.org Fanatic
 
Join Date: Jun 2007
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 3 Post(s)
Feedback Score: 0 reviews
That was my reply as well...........from the 6.0 Bible:

Chris4x4gill2 is offline  
post #4 of 5 Old 10-13-2009, 01:31 PM
Compression Ignition Addict
 
Join Date: Dec 2008
Location: port arthur texas
Posts: 4,222
Thanks: 1
Thanked 62 Times in 58 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
The only cover issue I remember was one for the water pump eating thru the cover and flooding the oil pan with water. But that was not on the 6.0 as best I remember.
dannyboy950 is offline  
post #5 of 5 Old 10-24-2009, 09:17 PM
Compression Ignition Addict
 
miles97's Avatar
 
Join Date: Oct 2008
Location: western wyoming
Posts: 227
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I had one about a year ago. A rock(i think) bounced up and lodged between the crank pulley and the oil pump cover. It broke the cover and as stated caused a no start.
miles97 is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome