Head Gasket Problem?? or Not?? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 3 Old 10-12-2009, 04:43 PM Thread Starter
Powerstroke.org Rookie
Join Date: Jun 2008
Posts: 21
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Head Gasket Problem?? or Not??

My truck is totally stock and just turned 100K about 3 months ago and is now up to 105K. The truck was given the once over by Ford at 98K other than two injectors. I am having no noticable issues..starts fine, power fine, runs smooth, no smoke since injector change, fuel mileage fine etc. Two weeks ago I was pulling a boat in traffic, light boat.. total weight under 3K pounds. I was in heavy traffic, flat terrain (central florida) and it was hot. I noticed the smell of antifreeze in the air, checked my guages (stock) and everything was in the middle. No steam coming out of the engine or anything like that but I felt like I needed to check..once I got out of traffic..no smell so I just moved on. Finished towing the boat another hour, then drove home another two hours, nothing out of the ordinary.

Next day I notice a strange sound from the engine compartment..like someone hitting a plastic jug. I noticed the Degas bottle was near empty so I filled it with distilled water and moved on..no sound.

Further inspection and I saw a white residue on the passenger side valve cover that hasn't been there, not a huge amount but some (don't know what that is, I keep things clean though)

With it having 100K I was going to start making some changes to make it a bit more bullet proof starting with the EGR valve delete treatment from BDPower. I'm wondering if I need to attack somewhere else now.

Is this a headgasket problem developing?
redfishpowerstroke is offline  
Sponsored Links
post #2 of 3 Old 10-12-2009, 04:52 PM
Compression Ignition Addict
Join Date: Jun 2009
Location: Molalla, Oregon
Posts: 957
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Sounds like maybe the heater control valve or possiobly hose clamps is/are leaking. it is on the heater hose over the valve cover. Hope this is it! the other things it could be are scarry, lol

Robsr is offline  
post #3 of 3 Old 10-12-2009, 06:47 PM
Compression Ignition Addict
speedycop732's Avatar
Join Date: Jun 2008
Location: Morgans Corner
Posts: 241
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Ive got a 05 and just did the same thing, I was stacking edge juice and sct and notice a smell of antifreeze. Im going to delete the egr cooler wednesday. My old 04 did the same friggen thing and it ended up being a cracked egr cooler. My guess is your losing ur water through the cap on the degas bottle due to the exhaust leaking through the cooler.

2002 CCSB 7.3 Leveled w/16.5x12s and 33s, TS 6 pos, 90k miles and counting (very slowly)

05 CC Lariat PSD S&B intake, SCT SF3, straight pipe with 5 inch tip, 2 inch lift, 33s on 12's more to come. Totaled - Knee busted up pretty bad and found out i cant swim as good as i thought
Pics on myspace bjdawgnewland@yahoo.com
speedycop732 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome