need help - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 10-01-2009, 12:18 AM
Powerstroke.org Rookie
 

Join Date: Sep 2009
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
need help

hey guys I'm looking for some input before I take my truck back in for the same issues I had 5 month ago.

First please keep in mind I brought it in 5 month ago and paid 300.00 only for them to tell me nothing is wrong.

Truck is 04 F350 with 86,000 miles. Everything Stock

First issue is in the morning when I start it up it idles very hard and if I don't let it warm up and take off it sounds like fire crakers or going off in the motor and runs like crap. Please note that it just started doing this as the temp has not dropped to the high 40's/low 50's. To me it doesn't seem that cold out to be doing this. Oil has just been change and fuel filters where changed 6000 miles ago.

Second issue I noticed now that I have my heat on in the cab is that when I come up to a stop light I loose most of my heat in the cab. This is the reason I brought it in last year and they said nothing was wrong but what ever they did fixed it for a few months. Then summer came so I didn't use my heat any more. I do see antifreeze that has puked out of the over flow. And I keep having to add more and more antifreeze. Not sure where it is going. Now I don't see any white smoke coming out so I really dont know what to think. I also dont really tow anything with this truck. At one point I did notice a little antifreeze coming from the passenger side wheel well on the back side of the motor. It wasn't much and I have only seen this once.

One more thing that my not be an issue but seems a little werid to be is that when I start my truck up I have always notice my tran temp come up really fast withing a mile or so from the time is started it. It doesn't over heat but just comes up really fast.

Please help me with any imput you may have I would like to get this fixed by the end of the year as I pretty sure my warrenty will be up.

Are there and Techs on here in the Minnesota Metro area? I would like to bring it to someone that i can trust to fix it right this time.

Thanks

Last edited by Borderwerx; 10-01-2009 at 12:29 AM.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 02:36 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors