show of hands egr delete now no boost! - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 8 Old 09-23-2009, 12:05 PM Thread Starter
Chapter Director
 
psd_va's Avatar
 
Join Date: Oct 2007
Location: Gloucester, va
Posts: 1,206
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
show of hands egr delete now no boost!

how many of you guys on here did an egr delete and now have low or no boost or have had this problem at one time. if you have had this problem and fixed it what did you do to fix please help?

03 F350 6.0 SRW 4X4 lariat

481hp 832tq

8" super lift 385/70r16 Toyo MT's
FatBoy traction bars
Durastroke stg1
intake
MBRP 5" straight pipe
Custom tuned by Vivian "Looney Wild Track"
Edge Insight CTS
Zoodad mod
high idle mod
6.4 banjo bolts
Updated fuel pressure regulator (Blue spring mod)
EGR cooler delete
6K 55w HID's
6k 35w fog HID's
B&W turnover ball


psd_va is offline  
Sponsored Links
Advertisement
 
post #2 of 8 Old 09-23-2009, 01:14 PM
Compression Ignition Addict
 
Join Date: Feb 2009
Posts: 195
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i still havent fixed it but i have the problem
powerstrokemonster is offline  
post #3 of 8 Old 09-23-2009, 02:30 PM
Powerstroke.org Rookie
 
Join Date: Jul 2007
Posts: 15
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Same here. Did EGR delete drove the truck for 1000 miles and Boost stopped. We think it is the Turbo Vane. Gonna replace tomorrow morning and let you know. May have something to do with the turbo passing water from a cracked EGR.
raustinf16 is offline  
post #4 of 8 Old 09-23-2009, 03:21 PM Thread Starter
Chapter Director
 
psd_va's Avatar
 
Join Date: Oct 2007
Location: Gloucester, va
Posts: 1,206
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yea I think it is my vanes too but just want to make sure before I go in for nothin

03 F350 6.0 SRW 4X4 lariat

481hp 832tq

8" super lift 385/70r16 Toyo MT's
FatBoy traction bars
Durastroke stg1
intake
MBRP 5" straight pipe
Custom tuned by Vivian "Looney Wild Track"
Edge Insight CTS
Zoodad mod
high idle mod
6.4 banjo bolts
Updated fuel pressure regulator (Blue spring mod)
EGR cooler delete
6K 55w HID's
6k 35w fog HID's
B&W turnover ball


psd_va is offline  
post #5 of 8 Old 09-23-2009, 08:13 PM Thread Starter
Chapter Director
 
psd_va's Avatar
 
Join Date: Oct 2007
Location: Gloucester, va
Posts: 1,206
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok so i have been doin some searchin around and have been seeing here and there that KOEO ebp sensor should be 14.7 +- .5 well i pretty sure mine dosen't read that much KOEO but i do know that at idle it runs at like 0psi. should i be worried can this be my problem. can any one confirm or deny this and help be a little more specific.

03 F350 6.0 SRW 4X4 lariat

481hp 832tq

8" super lift 385/70r16 Toyo MT's
FatBoy traction bars
Durastroke stg1
intake
MBRP 5" straight pipe
Custom tuned by Vivian "Looney Wild Track"
Edge Insight CTS
Zoodad mod
high idle mod
6.4 banjo bolts
Updated fuel pressure regulator (Blue spring mod)
EGR cooler delete
6K 55w HID's
6k 35w fog HID's
B&W turnover ball


psd_va is offline  
post #6 of 8 Old 09-23-2009, 08:28 PM
Compression Ignition Addict
 
Join Date: Dec 2007
Posts: 599
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ebp sensor?
thenubsterman is offline  
post #7 of 8 Old 09-23-2009, 08:54 PM
Powerstroke Techie

 
m-chan68's Avatar
 
Join Date: Jun 2008
Location: Brampton, Ontario, Canada
Posts: 2,584
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 4 Times in 3 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by psd_va View Post
ok so i have been doin some searchin around and have been seeing here and there that KOEO ebp sensor should be 14.7 +- .5 well i pretty sure mine dosen't read that much KOEO but i do know that at idle it runs at like 0psi. should i be worried can this be my problem. can any one confirm or deny this and help be a little more specific.
2003 model years trucks (or early 2004 model year trucks with 2003 engines) DO NOT use EBP sensor input to set turbo boost. They use what is called "inferred EBP", meaning a calculated value. This is why the VGT relearn procedure that is required after any major repair that involves turbo removal is necessary on (and EXCLUSIVELY on) 2003 model years. In a nutshell, the EBP sensor on 2003 model years, is just there to "look good".

http://www.yorkdaleford.com/service.html

Ford Diesel/Senior/Master Tech who placed 2nd overall in Ontario on the Fix-It-Right-First-Visit score for 2010

....who works at a dealership that now employs SOME half decent looking female employees since they overhauled most of the administrative staff

....but STILL loves hot women with big boobies

....and STILL hates working on E-Series with 6.0L
m-chan68 is offline  
post #8 of 8 Old 09-24-2009, 05:27 PM Thread Starter
Chapter Director
 
psd_va's Avatar
 
Join Date: Oct 2007
Location: Gloucester, va
Posts: 1,206
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
ok so i fixed my truck finally thank god. found that up pipe clamp at turbo and turbo housing clamp were not tight enough and were leaking pulled turbo back apart and didn't find any thing wrong so put back together and made sure i tighten those clamps more this time and ran after i started it i could tell it was better turbo was back to whistleing it a** off like it should and took it for a spin and the power is back. thought i would follow up and share what i found hope it maybe helps one of the others on here that are having this problem

03 F350 6.0 SRW 4X4 lariat

481hp 832tq

8" super lift 385/70r16 Toyo MT's
FatBoy traction bars
Durastroke stg1
intake
MBRP 5" straight pipe
Custom tuned by Vivian "Looney Wild Track"
Edge Insight CTS
Zoodad mod
high idle mod
6.4 banjo bolts
Updated fuel pressure regulator (Blue spring mod)
EGR cooler delete
6K 55w HID's
6k 35w fog HID's
B&W turnover ball


psd_va is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome