04, 6.0 sputters and loses power on hills - Ford Powerstroke Diesel Forum
Reply
 
LinkBack Thread Tools Display Modes
post #1 of 11 Old 09-17-2009, 11:35 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2009
Location: Bountiful, Utah
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
04, 6.0 sputters and loses power on hills

I have noticed latley that when going up the canyon highways my truck sputters; loses power...almost like it is stalling out, then catches again. I just recently had to get the FICM replaced when I randomly could no longer start my truck. I also changed my fuel filters. I had hoped that having that done would help or solve the problem. Not the case. Any suggestions of what might be happening? Thanks,


-Rich
richm is offline  
post #2 of 11 Old 09-17-2009, 11:42 AM
Serving Our Country!
 
Red_Powerstroke's Avatar
 
Join Date: Jul 2009
Location: Nathalie, Virginia
Posts: 44
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Mine is doing the same thing I was wondering if it was the turbo?

2004 F-250 6.0 CC SB FX4
Rough Country Leveling kit
35 x 12.50 x 16 Firestone Destination MT
Superchips Max MicroTuner
Dee Zee Heavyweight Truck Bed Mat
Westin Nerf Bars
Hump Mount For My Magnum S-3 CB
Banks Ram Air Intake




Red_Powerstroke is offline  
post #3 of 11 Old 09-18-2009, 08:49 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2009
Location: Bountiful, Utah
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I hope it's not an issue with the turbo($)...however at this point I just want to figure out what it is and get it resolved! I spoke to a buddy of mine who is quite knowledgeable with Fords...he suggested just using some fuel system clean-out (pour in fuel and let it run through system...supposedly cleaning out things). I tried this a couple weeks ago and nothing changed.

-Rich
richm is offline  
post #4 of 11 Old 09-18-2009, 05:44 PM
Compression Ignition Addict
 
Join Date: Feb 2009
Location: Fairfield, MT
Posts: 589
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Mine did this and I lost my fuel pump month later. When you pull out your upper filter does it look like its been twisted at all. If so thats the sign your pumps going out.
redsmoke is offline  
post #5 of 11 Old 09-18-2009, 05:45 PM
Compression Ignition Addict
 
Join Date: Feb 2009
Location: Fairfield, MT
Posts: 589
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I also had to replace my egr valve right after that to. It could be your egr valve. .
redsmoke is offline  
post #6 of 11 Old 09-18-2009, 05:46 PM
ADMIN AND TECH


 
SCUFFY828's Avatar
 
Join Date: Oct 2006
Location: winston salem north carolina
Posts: 9,316
Thanks: 0
Thanked 11 Times in 11 Posts
Mentioned: 0 Post(s)
Quoted: 1 Post(s)
Feedback Score: 0 reviews
egr valve is bad

SCUFFY828@POWERSTROKE.ORG
ITS STOCK
SCUFFY828 is offline  
post #7 of 11 Old 09-28-2009, 10:39 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Aug 2009
Location: Bountiful, Utah
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
I'll check the egr valve. Thanks!
richm is offline  
post #8 of 11 Old 09-28-2009, 10:53 PM
Serving Our Country!

 
f250ghost's Avatar
 
Join Date: Oct 2007
Location: Navarre, FL
Posts: 2,520
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Send a message via AIM to f250ghost Send a message via MSN to f250ghost Send a message via Yahoo to f250ghost
Could be in need of an oil change...mine does it everytime I'm about due an oil change. But I have an injector goin bad.

-Ben
2011 F250 FX4
6.7 PowerStroke
f250ghost is offline  
post #9 of 11 Old 09-29-2009, 11:28 AM
Compression Ignition Addict
 
Join Date: Mar 2007
Location: Springfield, VA
Posts: 380
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by f250ghost View Post
Could be in need of an oil change...mine does it everytime I'm about due an oil change. But I have an injector goin bad.
How often do you change your oil?


1991 Volkswagen Jetta 1.6TD ECOdiesel -- 423,000 miles
2003 Ford F-350 6.0 -- 131,000 miles
1987 Mercedes-Benz 300SDL -- 307,500 miles

2000 Volkswagen New Beetle TDI (RIP)
1987 Mercedes-Benz 190D 2.5 Turbo (sold)


Helpful Links:
6.0 no-start | 6.0 turbo reconditioning | Test your coolant!

VeeDubTDI is offline  
post #10 of 11 Old 09-29-2009, 01:27 PM
Serving Our Country!

 
f250ghost's Avatar
 
Join Date: Oct 2007
Location: Navarre, FL
Posts: 2,520
Thanks: 2
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 1 reviews
Send a message via AIM to f250ghost Send a message via MSN to f250ghost Send a message via Yahoo to f250ghost
With the injector going out I'm changin mine ever 2-4k miles. Once I change it it stops sputtering and everything...runs like a new truck.

-Ben
2011 F250 FX4
6.7 PowerStroke
f250ghost is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome