Cylinder 8 Glow Plug Circuit DTC P0683 - Ford Powerstroke Diesel Forum

Reply
 
LinkBack Thread Tools Display Modes
post #1 of 14 Old 09-08-2009, 04:34 PM Thread Starter
Click Click.......BOOOOM!
 
matt1030's Avatar
 
Join Date: Jun 2007
Location: Stoughton, MA
Posts: 329
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Cylinder 8 Glow Plug Circuit DTC P0683

Has anyone had this problem my truck is throwing P0683 Cylinder 8 Glow Plug Circuit. Is this a serious problem or just a loose connection? Any help would be great. Thanks

2012 F-350 6.7L 4X4 FX4
Lariat SuperCab Shortbed
matt1030 is offline  
post #2 of 14 Old 09-08-2009, 04:36 PM
duct tape & zip ties

 
bigcountrysg's Avatar
 
Join Date: Jul 2006
Location: Willis, MI
Posts: 10,761
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Could be faulty connection, could be a bad glow plug. Only way to find out is to remove the valve cover and take a look.


Your Actions Today, Decide Your Future Tomorrow

2005 6.0 Crew Cab Long Box Lariat, current truck

2004 6.0 destroyed by contaminated fuel

2002 7.3L burnt
bigcountrysg is offline  
post #3 of 14 Old 09-08-2009, 04:56 PM
Compression Ignition Addict
 
TurboSevenThree's Avatar
 
Join Date: Dec 2007
Location: Flint, MI
Posts: 4,057
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Quote:
Originally Posted by bigcountrysg View Post
Could be faulty connection, could be a bad glow plug. Only way to find out is to remove the valve cover and take a look.
Ditto. We can't tell that either. Go take a look.

Old Truck: 00 F350 XLT DRW: basic first few mods. S&B, 4" straight pipe, gauges, CCV, EBPV and Wastegate line deletes, LED Sills, sweet custom headlights, smoked cab lights, Ventshades, Tint.
Traded in at 196k miles.

"Brand Newish" Truck: 02 Chevy S10 2.2L 5sp. Reg cab 4x2. Badass custom made shifter, foglights, 20% tint, AVS Vent-shades, Stock Intake mods, Electric Fan conversion .
~ 95k miles.
TurboSevenThree is offline  
post #4 of 14 Old 09-08-2009, 05:05 PM
Compression Ignition Addict
 
03f250stroke's Avatar
 
Join Date: Sep 2007
Location: Toms River, NJ
Posts: 3,720
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to 03f250stroke
Quote:
Originally Posted by bigcountrysg View Post
Could be faulty connection, could be a bad glow plug. Only way to find out is to remove the valve cover and take a look.
pull the valve covers for what? the glow plugs are below the valve covers

-Evan

6.HO
tuned by Eric
12.3

Quote:
Originally Posted by shu873 View Post
Yeah, but your trucks a freak of nature...
03f250stroke is offline  
post #5 of 14 Old 09-08-2009, 05:08 PM
duct tape & zip ties

 
bigcountrysg's Avatar
 
Join Date: Jul 2006
Location: Willis, MI
Posts: 10,761
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Quote:
Originally Posted by 03f250stroke View Post
pull the valve covers for what? the glow plugs are below the valve covers
Yes they are. You have to pull the valve cover to check the glowplugs. Just to you let you know. Your injectors are under the valve cover too.


The problem maybe the under valve cover wiring harness. It maybe the connection on the outside of the valve cover. It could be a bad glow plug.

But the only way to find out is to pull the valve cover off. Check the wiring harness, pull the glow plug and check the ohms on it.

Don't worry the valve cover gasket is reuseable.


Your Actions Today, Decide Your Future Tomorrow

2005 6.0 Crew Cab Long Box Lariat, current truck

2004 6.0 destroyed by contaminated fuel

2002 7.3L burnt
bigcountrysg is offline  
post #6 of 14 Old 09-08-2009, 05:21 PM
Compression Ignition Addict
 
03f250stroke's Avatar
 
Join Date: Sep 2007
Location: Toms River, NJ
Posts: 3,720
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to 03f250stroke
Quote:
Originally Posted by bigcountrysg View Post
Yes they are. You have to pull the valve cover to check the glowplugs. Just to you let you know. Your injectors are under the valve cover too.


The problem maybe the under valve cover wiring harness. It maybe the connection on the outside of the valve cover. It could be a bad glow plug.

But the only way to find out is to pull the valve cover off. Check the wiring harness, pull the glow plug and check the ohms on it.

Don't worry the valve cover gasket is reuseable.
just so you know, they are NOT under the valve cover.

i just had my vc off sunday to check an injector.

the glow plugs are below the vc with its own harness. nothing glow plug related is under the vc

on my 03 i have a bus bar harness that has a connector up by the front of the motor. a deep socket 10mm will take the glow plugs out WITHOUT removing the vc. on the newer truck its a split loom harness. the glow plug connectors go into the rocker box like my 03 but with a different harness

-Evan

6.HO
tuned by Eric
12.3

Quote:
Originally Posted by shu873 View Post
Yeah, but your trucks a freak of nature...

Last edited by 03f250stroke; 09-08-2009 at 05:25 PM.
03f250stroke is offline  
post #7 of 14 Old 09-08-2009, 05:23 PM
duct tape & zip ties

 
bigcountrysg's Avatar
 
Join Date: Jul 2006
Location: Willis, MI
Posts: 10,761
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Quote:
Originally Posted by 03f250stroke View Post
just so you know, they are NOT under the valve cover.

i just had my vc off sunday to check an injector.

the glow plugs are below the vc with its own harness. nothing glow plug related is under the vc

on my 03 i have a bus bar harness that has a connector up by the front of the motor. a deep socket 10mm will take the glow plugs out WITHOUT removing the vc. on the newer truck its a split loom harness

So on a 6.0 they are outside of the valve cover.


Your Actions Today, Decide Your Future Tomorrow

2005 6.0 Crew Cab Long Box Lariat, current truck

2004 6.0 destroyed by contaminated fuel

2002 7.3L burnt
bigcountrysg is offline  
post #8 of 14 Old 09-08-2009, 05:25 PM
Compression Ignition Addict
 
Join Date: Jun 2007
Location: Albuquerque
Posts: 597
Thanks: 0
Thanked 1 Time in 1 Post
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 2 reviews
Send a message via Yahoo to chuckles
Quote:
Originally Posted by bigcountrysg View Post
So on a 6.0 they are outside of the valve cover.
yes, they actually have their own port on the rocker boxes.

Chuckles

07 F350 King Ranch. SCT by Innovative!! 4" Magnaflow Turboback, Coolant Fiter System, ARP Studs, Sneaky Pipe by Elite Diesel.
chuckles is offline  
post #9 of 14 Old 09-08-2009, 05:27 PM
Compression Ignition Addict
 
03f250stroke's Avatar
 
Join Date: Sep 2007
Location: Toms River, NJ
Posts: 3,720
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via AIM to 03f250stroke
Quote:
Originally Posted by chuckles View Post
yes, they actually have their own port on the rocker boxes.
correct. i just edited my post at the end.

ill post up some pictures tomorrow. my camera died as i was going outside to take a picture.

-Evan

6.HO
tuned by Eric
12.3

Quote:
Originally Posted by shu873 View Post
Yeah, but your trucks a freak of nature...
03f250stroke is offline  
post #10 of 14 Old 09-08-2009, 05:28 PM
duct tape & zip ties

 
bigcountrysg's Avatar
 
Join Date: Jul 2006
Location: Willis, MI
Posts: 10,761
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Send a message via Yahoo to bigcountrysg
Ok I thought they were like the 7.3L my bad.


Your Actions Today, Decide Your Future Tomorrow

2005 6.0 Crew Cab Long Box Lariat, current truck

2004 6.0 destroyed by contaminated fuel

2002 7.3L burnt
bigcountrysg is offline  
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome