still blowing white smoke after egr delete - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 09-04-2009, 04:22 AM
Powerstroke.org Rookie
 

Join Date: May 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
still blowing white smoke after egr delete

I got a 03 6.0 f250, egr cooler went, blowing white smoke. installed EGR delete from elite diesel. still blowing white smoke runs good up to 2000rpm and starts loosing power. coolant is not going anywere, any ideas?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 09-04-2009, 02:55 PM
Compression Ignition Addict
 

Join Date: Jun 2007
Location: Albuquerque
Posts: 597
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 2 reviews
Send a message via Yahoo to chuckles
when cold, warm?? Does it puke out the degaus bottle?
Reply With Quote Quick reply to this message
  #3  
Old 09-04-2009, 05:13 PM
Powerstroke Techie

 

Join Date: Jun 2008
Location: Brampton, Ontario, Canada
Posts: 2,584
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
For what it's worth, I have NEVER had to replace an EGR cooler on any '03 model year 6.0L yet, out of the thousands upon thousands of '04 to '07 model year EGR coolers I've replaced. Are you sure it's not an injector or two that is dumping fuel? '03 model year injectors tend to be more prone to this type of failure than the '04 to '07 ones.
Reply With Quote Quick reply to this message
  #4  
Old 09-05-2009, 03:59 AM
Powerstroke.org Rookie
 

Join Date: Sep 2009
Posts: 9
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
The problem sounds like the same as mine. Did Ford update the injectors for the 03
Reply With Quote Quick reply to this message
  #5  
Old 09-05-2009, 07:46 AM
Powerstroke.org Rookie
 

Join Date: May 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
found some probllems and fixed: hose from map sensor was broken due to customer had aftermarket (cheap) boost gauge installed himself. fixed. muffler filled with antifreeze (to the top) drained. still stummbles when u mash it to the floor @ around 2200 rpm then clears up i think the cat might be plugged also. doing a blance test and KoER test now.
Reply With Quote Quick reply to this message
  #6  
Old 09-05-2009, 12:02 PM
Compression Ignition Addict
 

Join Date: Jul 2009
Location: Welcome,N.C
Posts: 317
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I guess it is also possiable for the injector sleeves to leak to ! Right
Reply With Quote Quick reply to this message
  #7  
Old 09-05-2009, 02:32 PM
Compression Ignition Addict
 

Join Date: Feb 2007
Location: Jacksonville,Fl
Posts: 3,353
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 5 reviews
Send a message via AIM to Abrannan19
Quote:
Originally Posted by m-chan68 View Post
For what it's worth, I have NEVER had to replace an EGR cooler on any '03 model year 6.0L yet,

really!?!? Thats pretty amazing..cuz we have replaced a sh!t ton of them...and sold our delete kits to alot of 03 early 04 owners too...
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 03:52 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors