I dunno what's wrong! - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 4 Old 08-27-2009, 03:28 PM Thread Starter
Member
 
Purecetane22's Avatar
 
Join Date: Aug 2009
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Unhappy I dunno what's wrong!

I'm goin on a road trip here in about 4 weeks and need to figure this out. I got an 03 6.0. At about 2200 rpms on a highway in 4th my engine begins to cut out or stall. I notice black smoke out the stacks too. Turbo quits spoiling and engine cuts out acceleration only for a sec. Any ideas??? I was possibly told turbo problems then egr valve. Any suggestions?
Purecetane22 is offline  
Sponsored Links
Advertisement
 
post #2 of 4 Old 08-27-2009, 04:02 PM
Compression Ignition Addict
 
Join Date: Feb 2009
Location: Moose jaw,saskachewan,canada
Posts: 2,022
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 1 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
could be a combination of both.....I am not sure so here is a bump


06 F350 Traded
alwil is online now  
post #3 of 4 Old 08-28-2009, 11:42 AM
Compression Ignition Addict
 
Join Date: Mar 2007
Location: Springfield, VA
Posts: 380
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
In 4th? Does it do it in 5th while you're cruising?


1991 Volkswagen Jetta 1.6TD ECOdiesel -- 423,000 miles
2003 Ford F-350 6.0 -- 131,000 miles
1987 Mercedes-Benz 300SDL -- 307,500 miles

2000 Volkswagen New Beetle TDI (RIP)
1987 Mercedes-Benz 190D 2.5 Turbo (sold)


Helpful Links:
6.0 no-start | 6.0 turbo reconditioning | Test your coolant!

VeeDubTDI is offline  
post #4 of 4 Old 08-28-2009, 01:11 PM Thread Starter
Member
 
Purecetane22's Avatar
 
Join Date: Aug 2009
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Well at a steady 2200 rpm. Unpluged the egr valve and took off the diablo sport tuner. It deff helped. No mor hiccups as of now. Guna reload my sct tuner tonight
Purecetane22 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome