Turbo Problems? - Ford Powerstroke Diesel Forum
User Tag List

 
LinkBack Thread Tools Display Modes
post #1 of 6 Old 02-25-2006, 10:24 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2005
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Turbo Problems?

Last night I pulled a John Deere dozer home from work on a 35 foot dual tandem gooseneck trailer with my 03 F-250 PSD. About twenty miles into the two hour trip the truck was very sluggish taking off from idle thru 2000 rpm and no turbo noise at idle or reved up. This truck has a Banks exhaust so the turbo noise is always loud. Any idea's? The truck has about 60,000 miles on it, I took the Edge Juice w/ Attitude off about a month ago after reading about all the headgasket problems on here and had a friend remove the codes so I won't get the shaft from ford on the warranty. That also took away me being able to see if there is any boost. I traded in a 99 dodge cummins on this truck and have been VERY happy since coming over from the dark side! I guess I'm looking for a heads up before the Ford dealership gets ahold of my truck monday morning. Thanks
ryan6.0 is offline  
Sponsored Links
Advertisement
 
post #2 of 6 Old 02-25-2006, 12:31 PM
Compression Ignition Addict
 
wesjones's Avatar
 
Join Date: Sep 2005
Posts: 422
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
sounds like you canceled out any mod damage by taking the programer off...how heavy is the dozer...it may just be too much and the truck is conking out...we have a trailer at work with equipment over 15k and pull it with a 450...the truck has a very hard time goin up hills and starting...even though towing doesn't even phase these engines...the whole package isn't designed to tow in excess...

good luck with that
one good thing to do is run for codes just for the heck of it

wes
wesjones is offline  
post #3 of 6 Old 02-25-2006, 02:35 PM
Banned
 
Join Date: Jan 2006
Location: central coast, california
Posts: 0
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 5 Times in 3 Posts
Feedback Score: 0 reviews
did you hear a "pop" at all? if i was you i would check all four CAC tube connections, also look at the side tanks on your intercooler and see if the intercooler popped. usually when the vains of a turbo are giving problems, it is intermittent or is a surger at cruise, its usually not a totally inop turbo. sounds to me like a CAC problem.......Marc
mschn99 is offline  
post #4 of 6 Old 02-26-2006, 05:32 AM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2005
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Thanks guys, I'll do some looking today. The dozer and trailer togather are 27000 pounds. Other than the rough ride it pulled great, 75 down hills and 65 -70 up.
ryan6.0 is offline  
post #5 of 6 Old 02-27-2006, 03:56 AM
Compression Ignition Addict
 
Join Date: Jan 2006
Location: Theodore, AL
Posts: 228
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Just out of curiousity do you have a trans temp guage and if so how hot did it get when pulling this kinda load? I am just curious because I was wondering what kinda limits could be towed without the trans getting too hot.
pro99line is offline  
post #6 of 6 Old 02-28-2006, 03:42 PM Thread Starter
Powerstroke.org Rookie
 
Join Date: Dec 2005
Posts: 9
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Trans temp stayed right in the normal range, about where is stays during normal driving. Got the truck back last night and the dealership said the EGR valve was stuck open. Does this sound right? Anyway they replaced it and it's running great. They also said it will probably need injectors pretty soon.
ryan6.0 is offline  
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

 
For the best viewing experience please update your browser to Google Chrome