Fuel Pump? - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 08-16-2009, 11:57 AM Thread Starter
Powerstroke.org Rookie
Join Date: Aug 2009
Posts: 1
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Fuel Pump?

Had a few problems over the winter with 06 psd. Truck at the time only had around 35,000 miles. Has had 2 egrs replaced, oil cooler, and gaskets replaced. Has djs tunes (mostly run economy), 5" turbo back no cat but muffler, and zoodad mod. When driving down the road the truck starting shuttering as if running out of fuel but the tank was on a 1/4 then it cleared up. Parked the truck for about 3 hours then drove it again had no problem till about 5 miles in the truck begain to shutter again and then died out on me. I made it back home and put some fuel in it I thought maybe it was some bad fuel. After I fueld it up no problems. Now a few months later anytime I go below 1/4 tank and shut her down it misses when it starts as if it were out of fuel. I have replaced the fuel filter and also put it back to stock but still the same. Could this be the fuel pump? Injectors?. It almost seems like it looses its prime or somthing.
NYhc416 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome