Smells like antifreeze - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 08-16-2009, 10:51 AM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Smells like antifreeze

I just got it out of the shop drove 2000 miles and now I'm smelling antifreeze
when I stop through the ac and when I get out of the truck. Any one know what that's from?
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 08-16-2009, 10:52 AM
If it aint a CAT itsa DOG

 

Join Date: Apr 2007
Location: North Branch, MN
Posts: 4,553
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Welcome to the ORG. What did they work on at the shop? Anything egr cooler related?
Reply With Quote Quick reply to this message
  #3  
Old 08-16-2009, 10:59 AM
Banned
 

Join Date: May 2009
Location: Mankato MN
Posts: 71
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
?

Is your truck a 2003 or early 2004? Pop the hood and see first if you are pushing coolant out of the over flow jug but my guess would be the little hose that connects the egr cooler to the oil cooler is leaking.
Reply With Quote Quick reply to this message
  #4  
Old 08-16-2009, 11:02 AM
If it aint a CAT itsa DOG

 

Join Date: Apr 2007
Location: North Branch, MN
Posts: 4,553
Thanks: 0
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Yep, i think that was the orange hose that is replaced with a blue one IIRC. Usually those leak enough to drip on the ground though.
Reply With Quote Quick reply to this message
  #5  
Old 08-16-2009, 11:07 AM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Nothing egr related. I had alot of work done in the last 30,000 miles. All new injectors, at 90,000 miles. New bd turbo, with bd power elbow, bd bypass oil filter, and BG egr flush kit @ 110,000 miles. I've got 137,000 miles now and I took it in 2 months ago
because the turbo was getting extremely hot. There was a slice in the rubber from the intake at the turbo and they said that was it. It was also running pretty rough when I took it in. They said I might need a couple new injectors.
Reply With Quote Quick reply to this message
  #6  
Old 08-16-2009, 11:17 AM
Powerstroke.org Rookie
 

Join Date: Aug 2009
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Its an 04 f350 and I did notice that it had overflowed yesterday when I looked. I filled it up about an inch.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 04:36 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors