Issue with 4wd - Ford Powerstroke Diesel Forum
User Tag List

LinkBack Thread Tools Display Modes
post #1 of 1 Old 06-02-2013, 06:17 AM Thread Starter
Join Date: Feb 2013
Posts: 67
Mentioned: 0 Post(s)
Tagged: 0 Thread(s)
Quoted: 0 Post(s)
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Issue with 4wd

Hi there,

I have an issue with my 4wd system I click into 4high and sometimes it goes in other times it doesn't but when it does go in it doesn't feel quite right the rears will still spin up and then the front will spin slightly but no where near as much if at all.

When I click it into 4wd I got under and felt the prop and it was locked so it looks like it's shifting in ok and the light always comes on the dash saying it's locked in. I am just very unimpressed with the 4wd and try and not use it!

any suggestions on what to check?

Cheers Phil
Phi1 is offline  
Sponsored Links

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome