Cruise Control light works, no cruise - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 05-09-2013, 11:42 AM
Serving Our Country!
 

Join Date: Jan 2008
Location: South Lyon, MI
Posts: 324
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Cruise Control light works, no cruise

So if I hit my cruise control on, the light comes on the dash but the pedal doesnt stick and the cruise doesnt work. Brake lights work, abs light is not on, everything works fine minus the cruise.

where do I start the trouble shooting? Thanks
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 05-10-2013, 05:27 AM
Serving Our Country!
 

Join Date: Jan 2008
Location: South Lyon, MI
Posts: 324
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
and this is not the truck in my sig, its an 03 v10.
Reply With Quote Quick reply to this message
  #3  
Old 05-17-2013, 08:48 AM
Serving Our Country!
 

Join Date: Jan 2008
Location: South Lyon, MI
Posts: 324
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
No help? I have been browsing forums at work.

I have done the self diag test, and everything checks out all lights flash as they should. I have checked the fuses in the recall harness, visually checked the cables.

I'm at a loss here and really dont want to pay dealer for diag.

Any ford tech on here??????

Thanks
Reply With Quote Quick reply to this message
  #4  
Old 05-29-2013, 06:05 PM
Powerstroke.org Rookie
 

Join Date: May 2013
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
check the brake pressure switch on master cyl. it is the sensor sticking off the side. it is common the diaphram cracks and leaks. pull the flex loom back or unplug connector. if brake fluid is present its bad. if you have a multimeter see if you have continuity across the sensor with it unplugged. pressing brakes it will break the contact. or mayb its the other way around, i forget. to replace it. simply unscrew amd install new one with tephlon tape on threads. no need to bleed as long as brake pedal is not pushed when sensor is removed.
Reply With Quote Quick reply to this message
  #5  
Old 05-30-2013, 05:05 AM
Serving Our Country!
 

Join Date: Jan 2008
Location: South Lyon, MI
Posts: 324
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
It was the servo, the one on passenger side fender with the cable. $100 for a used one on ebay fixed me up.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Tags
abs, cruise control, light, pedal

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 01:29 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors