Rear hub seal replacement - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 04-07-2013, 02:51 PM
Powerstroke.org Rookie
 

Join Date: Sep 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Rear hub seal replacement

Hello Guys,
This is my first post on the forum since buying my truck back in September of last year and it's been great to me since then. However, 2 weeks ago I found a puddle of gear oil on the inside of my rear passenger side wheel. Went to Ford and received the part #2C3Z-1177-AB for a rear hub seal with them using my VIN.
After disassembling everything and driving in the new seal into the hub without issue, the hub will not go back onto the axle because the inside diameter is a tad too small on the seal. Tried heating it up to work it in but that still didn't help.
Been to Autozone, Napa, and O'Reilly's, each giving me something similar to what Ford gave me.

Truck is a 2007 F350 6.0L 4x4 SRW. Did they give me the wrong part, possibly for a DRW? The i.d. on the current seal is too destroyed to cross reference for size.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 04-19-2013, 05:46 AM
Powerstroke.org Rookie
 

Join Date: Nov 2009
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
How much too small are you talking about? When I replaced this same seal on my truck I remember it needing some work to get it reinstalled.
Reply With Quote Quick reply to this message
  #3  
Old 04-23-2013, 10:19 AM
Powerstroke.org Rookie
 

Join Date: Sep 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I was able to fix the problem yesterday.
Turns out that the old rear hub seal was more destroyed than I thought and split into 3 pieces. The metal ring to the seal was still on the axle, which I had mistaken for actually being part of the axle.
Removed that metal ring and the new seal along with the hub slid on without an issue.

Thanks for the help.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 11:33 PM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors