Need some ideas ! - Ford Powerstroke Diesel Forum
Powerstroke.org is the premier Diesel Truck Forum on the internet. Registered Users do not see the above ads.
Reply
 
LinkBack Thread Tools Display Modes
  #1  
Old 01-12-2013, 02:21 PM
Powerstroke.org Fanatic
 

Join Date: Mar 2012
Location: FT.Bragg
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Question Need some ideas !

whats up guys, ok so here is my issue. I have this weird jerking going on with my truck. Weather the truck is cold or completly warmed up, it still does it. Usually happens around 45-55 mph. My Edge is Not showing any troubles codes at all. Wich took out my first guess, witch was my injecors sticking. But last time I had an injector stick it, I threw a code and I was able to solve that issue with some T6. Can't be my EGR valve cause I have an EGR Delete correct ? So this leaves me thinking something is going on with my drivetrain / suspension. Now my plan is to get a list of things to check from you guys and then take it to a DIY shop and slap her up on a lift and go down the list and hopefully find the issue. Any thought is appreciated. Thanks guys !
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
  #2  
Old 01-12-2013, 03:29 PM
Member
 

Join Date: Jan 2013
Location: Crownsville
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i have the same issue and i was told that it sounds like my TC is going out and i have brand new 90hp injec and egr delete as well, once you get out of that MPH range it goes away right? cause thats what mine does and no codes
Reply With Quote Quick reply to this message
  #3  
Old 01-12-2013, 03:30 PM
Member
 

Join Date: Jan 2013
Location: Crownsville
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
does it actually feel more like a chatter then it does bucking?
Reply With Quote Quick reply to this message
  #4  
Old 01-12-2013, 03:33 PM
Banned
 

Join Date: Oct 2011
Location: Carrollton Ohio
Posts: 8,839
Thanks: 65
Thanked 58 Times in 40 Posts
Feedback Score: 10 reviews
Where are you guys getting these "90 HP Injectors" from lol this isn't a 7.3 or a Cummings.

OP sounds like the spool valves in your injectors are sticking and causing it to buck. Mine did the same thing ALL the way up until I replaced the injectors in Sept. last year. Now it runs like a top.
Reply With Quote Quick reply to this message
  #5  
Old 01-12-2013, 05:16 PM
Member
 

Join Date: Jan 2013
Location: Crownsville
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
i got my 90hp injectors from RCD with bench tests,and i tell you what it really woke the truck up with no tuner!
Reply With Quote Quick reply to this message
  #6  
Old 01-12-2013, 05:18 PM
Banned
 

Join Date: Oct 2011
Location: Carrollton Ohio
Posts: 8,839
Thanks: 65
Thanked 58 Times in 40 Posts
Feedback Score: 10 reviews
There is no such thing as a 90 hp injector for the 6.0 is what I'm saying lol. They are 155's, 175's, 190's, etc. etc. They may have been flowed and dyno'd at 90 hp but that isn't what the 6.0 performance world calls them.
Reply With Quote Quick reply to this message
  #7  
Old 01-12-2013, 05:57 PM
Member
 

Join Date: Jan 2013
Location: Crownsville
Posts: 62
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
http://www.rivercitydiesel.com/index...mart&Itemid=54
there ya go bud those are what i bought, and at 1500rpm they add 90hp at 2200rpm it went up to 115hp and so on up to 4k rpm but i dont go past 3k max
Reply With Quote Quick reply to this message
  #8  
Old 01-12-2013, 06:00 PM
Banned
 

Join Date: Oct 2011
Location: Carrollton Ohio
Posts: 8,839
Thanks: 65
Thanked 58 Times in 40 Posts
Feedback Score: 10 reviews
I'm aware that RCD sells them as "90 HP injectors" I'm simply saying that they are called by their barrel size not HP size in the 6.0 world. RCD has a weird way of doing things lol.
Reply With Quote Quick reply to this message
  #9  
Old 01-12-2013, 06:51 PM
Powerstroke.org Fanatic
 

Join Date: Mar 2012
Location: FT.Bragg
Posts: 112
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Tuscany View Post

OP sounds like the spool valves in your injectors are sticking and causing it to buck. Mine did the same thing ALL the way up until I replaced the injectors in Sept. last year. Now it runs like a top.
phhh this sucks, I was hoping it was going to be a modertly cheap fix . Is their someway I could test it by pulling my injector out and looking for something or maybe even have Ford hook it up to their computer's and tell me something
Reply With Quote Quick reply to this message
  #10  
Old 01-12-2013, 06:53 PM
Banned
 

Join Date: Oct 2011
Location: Carrollton Ohio
Posts: 8,839
Thanks: 65
Thanked 58 Times in 40 Posts
Feedback Score: 10 reviews
You can have Ford hook their I.D.S. up to it and find out which injector(s) it is. Also might want to try some Rev X or Archoil 9100 with Rotella T6 Full Synthetic Oil and see if it clears up.

If you decide to tear into it give Jesse Warren a call at Warren Diesel or Sheldon at Renegade Diesel and have them rebuild you a set of injectors. WAY cheaper than buying new or remans.
Reply With Quote Quick reply to this message
Sponsored Links
Advertisement
 
Reply

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.



Thread Tools
Display Modes

Posting Rules
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On



All times are GMT -8. The time now is 10:58 AM.


Powered by vBulletin® Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Search Engine Optimization by vBSEO 3.6.1
Garage Plus, Vendor Tools vBulletin Plugins by Drive Thru Online, Inc.

vB.Sponsors