Problem with 4X4 Please Help - Ford Powerstroke Diesel Forum
LinkBack Thread Tools Display Modes
post #1 of 2 Old 10-13-2011, 03:24 PM Thread Starter Rookie
Join Date: May 2010
Location: Hoffman Estates
Posts: 29
Thanks: 0
Thanked 0 Times in 0 Posts
Mentioned: 0 Post(s)
Quoted: 0 Post(s)
Feedback Score: 0 reviews
Exclamation Problem with 4X4 Please Help

I tried to engage the 4X4 today and no power to the front wheels, front drive shaft does spin but still no power. the lights on the dash stay solid lit and don't flash as if there was an error if I'm remembering correctly.

Could it be the selector hubs are shot or does this sound like an internal front end is trashed.

2005 f-250
171,000 miles
Edge Tuner in towing mode. I get on it in 2WD but am easy on it when in 4WD.
Worked fine all last winter.

2005powerstroke is offline  
post #2 of 2 Old 10-13-2011, 03:40 PM
information regurgitator

NYC F-350's Avatar
Join Date: Dec 2010
Location: Epping, NH
Posts: 6,350
Thanks: 37
Thanked 270 Times in 246 Posts
Mentioned: 15 Post(s)
Quoted: 49 Post(s)
Feedback Score: 0 reviews
Try locking the hubs in manually. If that works, you could just have a simple vacuum leak somewhere.
NYC F-350 is offline  

Quick Reply

Register Now

In order to be able to post messages on the Ford Powerstroke Diesel Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Please enter a password for your user account. Note that passwords are case-sensitive.


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:


Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.

Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode

Posting Rules  
You may post new threads
You may post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On

For the best viewing experience please update your browser to Google Chrome